Driver Problems? Questions? Issues?
Put OSR's experience to work for you! Contact us for assistance with:
  • Creating the right design for your requirements
  • Reviewing your existing driver code
  • Analyzing driver reliability/performance issues
  • Custom training mixed with consulting and focused directly on your specific areas of interest/concern.
Check us out. OSR, the Windows driver experts.

OSR Seminars


Go Back   OSR Online Lists > ntdev
Welcome, Guest
You must login to post to this list
  Message 1 of 3  
12 Jul 18 19:13
ff fab
xxxxxx@igt.com
Join Date: 03 Mar 2016
Posts To This List: 8
[USB] Win32 SP1 vs SP3

Hello, I have an USB functional driver (KMDF) that has been running for years on win32 SP1. I am attempting to install the driver on a target running Win32 SP3. The driver does not run and fails with error code 39. The same driver package does install and run on SP1, is there a problem the coinstaller itself or is my binary at fault ? the log is as follow [SetupAPI Log] OS Version = 5.1.2600 Service Pack 3 Platform ID = 2 (NT) Service Pack = 3.0 Suite = 0x0100 Product Type = 1 Architecture = x86 [2018/07/12 16:00:23 3688.238] #-198 Command line processed: "C:\WINDOWS\system32\mmc.exe" /s C:\WINDOWS\system32\compmgmt.msc #-148 Loading coinstaller modules for "CR APP Interface". #E144 Loading module "C:\WINDOWS\system32\WdfCoInstaller01011.dll" failed. Error 127: The specified procedure could not be found.
  Message 2 of 3  
12 Jul 18 19:34
Tim Roberts
xxxxxx@probo.com
Join Date: 28 Jan 2005
Posts To This List: 12008
[USB] Win32 SP1 vs SP3

xxxxx@igt.com wrote: > I have an USB functional driver (KMDF) that has been running for years on win32 SP1. > > I am attempting to install the driver on a target running Win32 SP3. The driver does not run and fails with error code 39. There is no operating system called Win32.  From your version number, it appears you actually mean XP SP1 and XP SP3. > The same driver package does install and run on SP1, is there a problem the coinstaller itself or is my binary at fault ? the log is as follow > > [SetupAPI Log] > OS Version = 5.1.2600 Service Pack 3 > Platform ID = 2 (NT) > Service Pack = 3.0 > Suite = 0x0100 > Product Type = 1 > Architecture = x86 <...excess quoted lines suppressed...> KMDF 1.11 does not work on XP.  That requires at least Vista.  If you really need to support XP, then you need to back down to KMDF 1.9. -- Tim Roberts, xxxxx@probo.com Providenza & Boekelheide, Inc.
  Message 3 of 3  
12 Jul 18 19:41
ff fab
xxxxxx@igt.com
Join Date: 03 Mar 2016
Posts To This List: 8
[USB] Win32 SP1 vs SP3

Thank you for setting me straight.
Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You must login to OSR Online AND be a member of the ntdev list to be able to post.

All times are GMT -5. The time now is 19:19.


Copyright ©2015, OSR Open Systems Resources, Inc.
Based on vBulletin Copyright ©2000 - 2005, Jelsoft Enterprises Ltd.
Modified under license