Driver Problems? Questions? Issues?
Put OSR's experience to work for you! Contact us for assistance with:
  • Creating the right design for your requirements
  • Reviewing your existing driver code
  • Analyzing driver reliability/performance issues
  • Custom training mixed with consulting and focused directly on your specific areas of interest/concern.
Check us out. OSR, the Windows driver experts.

OSR Seminars


Go Back   OSR Online Lists > ntdev
Welcome, Guest
You must login to post to this list
  Message 1 of 4  
12 Feb 18 11:33
Eva Brigid
xxxxxx@gmail.com
Join Date: 12 Feb 2018
Posts To This List: 12
Windows Hardware Lab Kit (HLK) hangs on WFP Validation when trying to WFPLogo

Why is WFPLogo.exe hanging for the Validate WFP test? I setup HLK 10 on Windows Server 2016 for controller and test server. I scheduled tasks for my WFP driver and the first two suites completed successfully. However, the WindowsFilteringPlatform_tests hands on Validated WFPUsage and it seems to be running: WFPLogo.Exe -t "\ArchitecturalDesign\Validate.WFPUsage" -l Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.Validate.WFPUsage.NTLo g -r When I run this locally, the tool opens a file with a series of questions for me to fill out and save. I don't quite know how to configure my HLK studio project so it already has the information so they system doesn't halt. From the documentation (https://docs.microsoft.com/en-us/windows-hardware/test/hlk/testref/windows-filte ring-platform--wfp--drivers-testing-prerequisites) it seems that I should populate WFPLogo.Answer or WFPLogo.Info to avoid this problem. It is unclear to me how to get these to the test system as they are copied when the binaries are copied. Am I supposed to alter the sql playlist or the default set of files installed by HLK on my controller? This seems wrong, I'd expect to configure this in the project but I see no UI for this scenario and the document isn't as full on this topic I'd hope. Am I missing a step on the HLK setup and project configuration? Thanks Eva
  Message 2 of 4  
13 Feb 18 18:14
Eva Brigid
xxxxxx@gmail.com
Join Date: 12 Feb 2018
Posts To This List: 12
Windows Hardware Lab Kit (HLK) hangs on WFP Validation when trying to WFPLogo

I may have a partial answer. On HLK controller the default WFPLogo.info files in C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests amd64\nttest\NetTest\SecureNet\WFPTest and x86\nttest\NetTest\SecureNet\WFPTest need to be replace with your customized version. At least this seems to have worked in my case.
  Message 3 of 4  
20 Feb 18 16:54
Eva Brigid
xxxxxx@gmail.com
Join Date: 12 Feb 2018
Posts To This List: 12
Windows Hardware Lab Kit (HLK) hangs on WFP Validation when trying to WFPLogo

turns out I had a flaw in my answers file "UseAnswerFile = 0" was the 2nd issue. I still don't know if changing the file contents beneath C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests\amd64\nttest\NetTest\SecureNet\WFPTest and x86\nttest\NetTest\SecureNet\WFPTest is the best choice
  Message 4 of 4  
21 Feb 18 10:26
Eva Brigid
xxxxxx@gmail.com
Join Date: 12 Feb 2018
Posts To This List: 12
Windows Hardware Lab Kit (HLK) hangs on WFP Validation when trying to WFPLogo

Found the final issue via a msdn post - https://social.msdn.microsoft.com/Forums/en-US/bcad7de2-6d39-4f4c-94d4-54bddd7e76 0a/hck-wfplogo-test-fwpmprovidersmaintainidentifying-fails-frequently-but-not-alw ays?forum=wfp The provider.displayData.name must equal the string value of the WFPLogo.Info's CompanyName. The provider.displayData.description must contain the string value of the WFPLogo.Info's ProductName. Once I brought those and WFPAnswer.info in sync I could run and pass the tests.
Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You must login to OSR Online AND be a member of the ntdev list to be able to post.

All times are GMT -5. The time now is 13:01.


Copyright ©2015, OSR Open Systems Resources, Inc.
Based on vBulletin Copyright ©2000 - 2005, Jelsoft Enterprises Ltd.
Modified under license